[USACO07JAN] Balanced Lineup G ST算法

发布时间:2024年01月16日

[USACO07JAN] Balanced Lineup G

题目描述

For the daily milking, Farmer John’s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 180,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

每天,农夫 John 的 n ( 1 ≤ n ≤ 5 × 1 0 4 ) n(1\le n\le 5\times 10^4) n(1n5×104) 头牛总是按同一序列排队。

有一天, John 决定让一些牛们玩一场飞盘比赛。他准备找一群在队列中位置连续的牛来进行比赛。但是为了避免水平悬殊,牛的身高不应该相差太大。John 准备了 q ( 1 ≤ q ≤ 1.8 × 1 0 5 ) q(1\le q\le 1.8\times10^5) q(1q1.8×105) 个可能的牛的选择和所有牛的身高 h i ( 1 ≤ h i ≤ 1 0 6 , 1 ≤ i ≤ n ) h_i(1\le h_i\le 10^6,1\le i\le n) hi?(1hi?106,1in)。他想知道每一组里面最高和最低的牛的身高差。

输入格式

Line 1: Two space-separated integers, N and Q.

Lines 2…N+1: Line i+1 contains a single integer that is the height of cow i

Lines N+2…N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

第一行两个数 n , q n,q n,q

接下来 n n n 行,每行一个数 h i h_i hi?

再接下来 q q q 行,每行两个整数 a a a b b b,表示询问第 a a a 头牛到第 b b b 头牛里的最高和最低的牛的身高差。

输出格式

Lines 1…Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

输出共 q q q 行,对于每一组询问,输出每一组中最高和最低的牛的身高差。

样例 #1

样例输入 #1

6 3
1
7
3
4
2
5
1 5
4 6
2 2

样例输出 #1

6
3
0
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
const int N = 50005;
int cow[N], dp_max[N][22], dp_min[N][22];
int LOG2[N];
int n, q;
void init(){
    LOG2[0] = -1;
    for (int i = 1; i <= N ; i++){
        LOG2[i] = LOG2[i >> 1] + 1;
    }//计算LOG2[]
    for (int i = 1; i <= n;i++){//找到每个长度为1的小区间的最小值最大值
        dp_max[i][0] = cow[i];
        dp_min[i][0] = cow[i];
    }
    int p = log2(n);//可倍增的最大次方
    for (int k = 1; k <= p;k++){//倍增计算小区间,先算小区间,再算大区间,逐步递推
        for (int s = 1; s + (1 << k) <= n + 1; s++){
            dp_max[s][k] = max(dp_max[s][k - 1], dp_max[s + (1 << (k - 1))][k - 1]);
            dp_min[s][k] = min(dp_min[s][k - 1], dp_min[s + (1 << (k - 1))][k - 1]);
        }
    }
}

int getans(int L,int R){
    int len = R - L + 1;
    int k = LOG2[len];
    int x = max(dp_max[L][k], dp_max[R - (1 << k) + 1][k]);
    int y = min(dp_min[L][k], dp_min[R - (1 << k) + 1][k]);
    return x - y;
}
int main(){
    scanf("%d%d", &n, &q);
    for (int i = 1; i <= n; i++){
        scanf("%d", &cow[i]);
    }
    init();
    int L;
    int R;
    while(q--){
        scanf("%d%d", &L, &R);
        int ans = getans(L, R);
        printf("%d\n", ans);
    }
    return 0;
}

文章来源:https://blog.csdn.net/MuQYun/article/details/135581817
本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。