?
资源限制
内存限制:256.0MB ? C/C++时间限制:1.0s ? Java时间限制:3.0s ? Python时间限制:5.0s
问题描述
编写一个程序,不断输入字符直到遇到’#’为止。然后输出读入的空格’ ’,换行符’\n’和其它字符个数。(注:最后的‘#’不计入其他字符)
样例输入
Chapter 1. Getting Ready
Chapter 2. Introducing C
Chapter 3. #
样例输出
8 2 51
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
String str = "";
int space = 0;
int n = 0;
int other = 0;
while (true) {
String input = sc.nextLine();
if (input.endsWith("#")) {
str += input.substring(0, input.length() - 1);
n--;
break;
} else {
str += input;
n++;
}
}
for (char ch : str.toCharArray()) {
if (ch == ' ') {
space++;
} else if (ch != '#') {
other++;
}
}
sc.close();
n += 1;
System.out.print(space + " " + n + " " + other);
}
}