【问题描述】输入一组无序的整数,编程输出其中出现次数最多的整数及其出现次数。
【输入形式】先从标准输入读入整数的个数(大于等于1,小于等于100),然后在下一行输入这些整数,各整数之间以一个空格分隔。
【输出形式】在标准输出上输出出现次数最多的整数及其出现次数,两者以一个空格分隔;若出现次数最多的整数有多个,则按照整数升序分行输出。
【样例输入】
10
0 -50 0 632 5813 -50 9 -50 0 632
【样例输出】
-50 3
0 3
【样例说明】
输入了10个整数,其中出现次数最多的是-50和0,都是出现3次。
参考代码示例:
import java.util.ArrayList;
import java.util.Collections;
import java.util.Map;
import java.util.Scanner;
import java.util.TreeMap;
public class Map {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
ArrayList<Integer> numb = new ArrayList<Integer>();
Map<Integer, Integer> count = new TreeMap<Integer, Integer>();
int n = sc.nextInt();
while(n-->0) {
numb.add(sc.nextInt());
}
Collections.sort(numb);
for(Integer a:numb) {
count.put(a, numb.lastIndexOf(a)-numb.indexOf(a)+1);
}
int index=-1;
for(Integer m:count.keySet()) {
if(count.get(m)>index) {
index=count.get(m);
}
}
for(Integer u:count.keySet()) {
if(count.get(u)==index) {
System.out.println(u+" "+count.get(u));
}
}
sc.close();
}
}