模拟队列

发布时间:2024年01月24日

输入样例:
10
push 6
empty
query
pop
empty
push 3
push 4
pop
query
push 6
输出样例:
NO
6
YES
4
import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int m = sc.nextInt();
        int[] q = new int[100010];
        int hh = 0; //头
        int tt = -1;//尾
        while (m-- > 0){
            String s = sc.next();
            if (s.equals("push")){
                int x = sc.nextInt();
                q[++tt] = x;
            } else if (s.equals("pop")){
                hh++;
            } else if (s.equals("empty")){
                if (hh<=tt) System.out.println("NO");
                else System.out.println("YES");
            } else
                System.out.println(q[hh]);
        }
    }
}

文章来源:https://blog.csdn.net/2302_76649176/article/details/135824793
本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。