SCAU:18059 学生成绩表

发布时间:2023年12月19日

18059?学生成绩表

时间限制:1000MS? 代码长度限制:10KB
提交次数:0 通过次数:0

题型: 填空题???语言: G++;GCC;VC

Description

输入10个学生,每个学生的数据包括学号、姓名、3门课的成绩。定义结构体类型表示学生类型,输入10个学生的数据,
计算每个学生的平均成绩。按平均成绩由高到低输出所有学生信息,成绩相同时按学号从小到大输出。


#include?<stdio.h>

struct?data
{
_______________________
};

int?main()
{
????int?i,j;
????struct?data?stu[10],tmp;
????for(i=0;?i<10;?i++)
????{
_______________________
????}
????for(i=0;?i<9;?i++)
????????for(j=0;?j<9-i;?j++)
????????{
_______________________
????????}
????for(i=0;?i<10;?i++)
????{
????????printf("%d?%s?%.0lf?%.0lf?%.0lf\n",?stu[i].num,?stu[i].name,?stu[i].score[0],?stu[i].score[1],?stu[i].score[2]);
????}
????return?0;
}

?

输入格式

10个学生信息,每行一个学生

输出格式

如题

输入样例

1 aaa 50 60 70
2 bbb 50 50 50
3 ccc 60 70 80
4 ddd 40 40 40 
5 eee 70 80 90
6 fff 30 30 30 
7 ggg 80 90 100
8 hhh 20 20 20
9 iii 100 100 100
10 jjj 10 10 10

输出样例

9 iii 100 100 100
7 ggg 80 90 100
5 eee 70 80 90
3 ccc 60 70 80
1 aaa 50 60 70
2 bbb 50 50 50
4 ddd 40 40 40 
6 fff 30 30 30 
8 hhh 20 20 20
10 jjj 10 10 10
#include <stdio.h>

struct data
{
    int num;
    char name[20];//注意是字符数组
    double score[3];//注意题目在输出的时候用了%lf格式输出,有提示score[]的类型是double
};

int main()
{
    int i,j;
    struct data stu[10],tmp;//注意题目给了的tmp的作用
    for(i=0; i<10; i++)
    {
        scanf("%d%s%lf%lf%lf",&stu[i].num,&stu[i].name,&stu[i].score[0],&stu[i].score[1],&stu[i].score[2]);
    }
    for(i=0; i<9; i++)
        for(j=0; j<9-i; j++)
        {
            if((stu[j].score[0]+stu[j].score[1]+stu[j].score[2])<(stu[j+1].score[0]+stu[j+1].score[1]+stu[j+1].score[2]))//注意这里是a[j]和a[j+1]比较,题目已经给出i和j的数值范围,要根据题目来选择排序方法
            {
                tmp=stu[j];//包含了stu[j]内所有的数据
                stu[j]=stu[j+1];
                stu[j+1]=tmp;
            }
        }
    for(i=0; i<10; i++)
    {
        printf("%d %s %.0lf %.0lf %.0lf\n", stu[i].num, stu[i].name, stu[i].score[0], stu[i].score[1], stu[i].score[2]);
    }
    return 0;
}

?

文章来源:https://blog.csdn.net/zero_019/article/details/135096630
本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。