CF1446B Catching Cheaters 题解 DP

发布时间:2024年01月15日

Catching Cheaters

传送门

题面翻译

给我们两个字符串,让我们从中选出两个字串,算出它们的最大公共子序列长度。然后将它乘 4 4 4在减去两个字串的长度。问你这个数最大是多少。

题目描述

You are given two strings A A A and B B B representing essays of two students who are suspected cheaters. For any two strings C C C , D D D we define their similarity score S ( C , D ) S(C,D) S(C,D) as 4 ? L C S ( C , D ) ? ∣ C ∣ ? ∣ D ∣ 4\cdot LCS(C,D) - |C| - |D| 4?LCS(C,D)?C?D , where L C S ( C , D ) LCS(C,D) LCS(C,D) denotes the length of the Longest Common Subsequence of strings C C C and D D D .

You believe that only some part of the essays could have been copied, therefore you’re interested in their substrings.

Calculate the maximal similarity score over all pairs of substrings. More formally, output maximal S ( C , D ) S(C, D) S(C,D) over all pairs ( C , D ) (C, D) (C,D) , where C C C is some substring of A A A , and $ D $ is some substring of B B B .

If X X X is a string, ∣ X ∣ |X| X denotes its length.

A string a a a is a substring of a string b b b if a a a can be obtained from b b b by deletion of several (possibly, zero or all) characters from the beginning and several (possibly, zero or all) characters from the end.

A string a a a is a subsequence of a string b b b if a a a can be obtained from b b b by deletion of several (possibly, zero or all) characters.

Pay attention to the difference between the substring and subsequence, as they both appear in the problem statement.

You may wish to read the Wikipedia page about the Longest Common Subsequence problem.

输入格式

The first line contains two positive integers n n n and m m m ( 1 ≤ n , m ≤ 5000 1 \leq n, m \leq 5000 1n,m5000 ) — lengths of the two strings A A A and B B B .

The second line contains a string consisting of n n n lowercase Latin letters — string A A A .

The third line contains a string consisting of m m m lowercase Latin letters — string B B B .

输出格式

Output maximal S ( C , D ) S(C, D) S(C,D) over all pairs ( C , D ) (C, D) (C,D) , where C C C is some substring of A A A , and D D D is some substring of B B B .

样例 #1

样例输入 #1

4 5
abba
babab

样例输出 #1

5

样例 #2

样例输入 #2

8 10
bbbbabab
bbbabaaaaa

样例输出 #2

12

样例 #3

样例输入 #3

7 7
uiibwws
qhtkxcn

样例输出 #3

0

提示

For the first case:

abb from the first string and abab from the second string have LCS equal to abb.

The result is S ( a b b , a b a b ) = ( 4 ? ∣ a b b ∣ ) ? ∣ a b b ∣ ? ∣ a b a b ∣ = 4 ? 3 ? 3 ? 4 = 5 S(abb, abab) = (4 \cdot |abb|) - |abb| - |abab| = 4 \cdot 3 - 3 - 4 = 5 S(abb,abab)=(4?abb)?abb?abab=4?3?3?4=5 .

解题思路

首先,暴力肯定过不了。

考虑DP。设 f i , j f_{i,j} fi,j? 表示以 a i , b i a_i,b_i ai?,bi? 为两字串的末位的相似值(相似值计算: 4 × L C S ( A , B ) ? ∣ A ∣ ? ∣ B ∣ 4 \times LCS(A,B)-|A|-|B| 4×LCS(A,B)?A?B)。当 i + 1 i+1 i+1 j + 1 j+1 j+1 时,对 L C S ( A , B ) LCS(A,B) LCS(A,B) 无贡献,而对 ∣ A ∣ |A| A ∣ B ∣ |B| B 贡献为 1 1 1,所以对相似值贡献为 ( 4 × L C S ( A ′ , B ) ? ∣ A ′ ∣ ? ∣ B ∣ ) ? ( 4 × L C S ( ∣ A ∣ , ∣ B ∣ ) ? ∣ A ∣ ? ∣ B ∣ ) = ( 4 × L C S ( A , B ) ? ( ∣ A ∣ + 1 ) ? ∣ B ∣ ) ? ( 4 × L C S ( A , B ) ? ∣ A ∣ ? ∣ ∣ B ) = 4 ? L C S ( A , B ) ? ∣ A ∣ ? 1 ? ∣ B ∣ ? 4 × L C S ( A , B ) + ∣ A ∣ + ∣ B ∣ = ? 1 (4\times LCS(A',B)-|A'|-|B|)-(4\times LCS(|A|,|B|)-|A|-|B|)=(4\times LCS(A,B)-(|A|+1)-|B|)-(4\times LCS(A,B)-|A|-||B)=4*LCS(A,B)-|A|-1-|B|-4\times LCS(A,B)+|A|+|B|=-1 (4×LCS(A,B)?A?B)?(4×LCS(A,B)?A?B)=(4×LCS(A,B)?(A+1)?B)?(4×LCS(A,B)?A?∣∣B)=4?LCS(A,B)?A?1?B?4×LCS(A,B)+A+B=?1,则有 f i , j = max ? ( f i , j , max ? ( f i ? 1 , j , f i , j ? 1 ) ) f_{i,j}=\max(f_{i,j},\max(f_{i-1,j},f_{i,j-1})) fi,j?=max(fi,j?,max(fi?1,j?,fi,j?1?))。当 i + 1 i+1 i+1 j + 1 j+1 j+1 的同时满足 a i + 1 = b j + 1 a_{i+1}=b_{j+1} ai+1?=bj+1?,则对 L C S ( A , B ) LCS(A,B) LCS(A,B) 的贡献为 4 4 4,对 ∣ A ∣ + ∣ B ∣ |A|+|B| A+B 的贡献为 2 2 2,所以对相似值的贡献为 ( 4 × L C S ( A ′ , B ′ ) ? ∣ A ′ ∣ ? ∣ B ′ ∣ ) ? ( 4 × L C S ( A , B ) ? ∣ A ∣ ? ∣ B ∣ ) = ( 4 × ( L C S ( A , B ) + 1 ) ? ( ∣ A ∣ + 1 ) ? ( ∣ B ∣ + 1 ) ) ? ( 4 × L C S ( A , B ) ? ∣ A ∣ ? ∣ B ∣ ) = ( 4 × L C S ( A , B ) + 4 ? ∣ A ∣ ? 1 ? ∣ B ∣ ? 1 ) ? ( 4 × L C S ( A , B ) ? ∣ A ∣ ? ∣ B ∣ ) = 4 × L C S ( A , B ) + 4 ? ∣ A ∣ ? 1 ? ∣ B ∣ ? 1 ? 4 × L C S ( A , B ) + ∣ A ∣ + ∣ B ∣ = 2 (4\times LCS(A',B')-|A'|-|B'|)-(4\times LCS(A,B)-|A|-|B|)=(4\times (LCS(A,B)+1)-(|A|+1)-(|B|+1))-(4\times LCS(A,B)-|A|-|B|)=(4\times LCS(A,B)+4-|A|-1-|B|-1)-(4\times LCS(A,B)-|A|-|B|)=4\times LCS(A,B)+4-|A|-1-|B|-1-4\times LCS(A,B)+|A|+|B|=2 (4×LCS(A,B)?A?B)?(4×LCS(A,B)?A?B)=(4×(LCS(A,B)+1)?(A+1)?(B+1))?(4×LCS(A,B)?A?B)=(4×LCS(A,B)+4?A?1?B?1)?(4×LCS(A,B)?A?B)=4×LCS(A,B)+4?A?1?B?1?4×LCS(A,B)+A+B=2,由此可得此时 f i , j = f i ? 1 , j ? 1 + 2 f_{i,j}=f_{i-1,j-1}+2 fi,j?=fi?1,j?1?+2

AC Code

#include <bits/stdc++.h>
using namespace std;
#define int long long
const int Maxn = 5000 + 5;
int n, m;
char s1[Maxn], s2[Maxn];
int f[Maxn][Maxn];
int ans;
inline void work() {
	cin >> n >> m >> s1 + 1 >> s2 + 1;
	for (int i = 1; i <= n; i++) {
		for (int j = 1; j <= m; j++) {
			f[i][j] = max(f[i][j], max(f[i][j - 1], f[i - 1][j]) - 1);
			if (s1[i] == s2[j]) {
				f[i][j] = f[i - 1][j - 1] + 2;
			}
			ans = max(ans, f[i][j]);
		}
	}
	cout << ans << endl;
}
signed main() {
	ios::sync_with_stdio(false);
	cin.tie(0);
	cout.tie(0);
	work();
	return 0;
}

还不会?看这里

文章来源:https://blog.csdn.net/BestMonkey/article/details/135593768
本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。