大疆笔试题目(2023-08-13)

发布时间:2024年01月19日

1. 输出无重复3位数

时间限制: 3000MS
内存限制: 65536KB
题目描述:
从{1,2,3,4,5,6,7,8,9}中随机挑选不重复的5个数字作为输入数组’selectedDigits’,能组成多少个互不相同且无重复数字的3位数?请编写程序,从小到大顺序,以数组形式,输这些3位数。

输入描述
selectedDigits = {1,2,3,4,5}

输出描述
123 124 125 132 134 135 142 143 145 152 153 154 213 214 215 231 234 235 241 243 245 251 253 254 312 314 315 321 324 325 341 342 345 351 352 354 412 413 415 421 423 425 431 432 435 451 452 453 512 513 514 521 523 524 531 532 534 541 542 543

样例输入
5
1 2 3 4 5
样例输出
123 124 125 132 134 135 142 143 145 152 153 154 213 214 215 231 234 235 241 243 245 251 253 254 312 314 315 321 324 325 341 342 345 351 352 354 412 413 415 421 423 425 431 432 435 451 452 453 512 513 514 521 523 524 531 532 534 541 542 543

提示
整型数组

数据格式:以空格分隔的整型数字。

样例:

1 2 3

#include <iostream>
#include <vector>
#include <numeric>
#include <limits>

using namespace std;

class Solution {
    vector<int> res;
    void dfs(vector<int>& selectedDigits, vector<int> cur, vector<bool>& isUsed) {
        if (cur.size() == 3) {
            res.push_back(cur[0] * 100 + cur[1] * 10 + cur[2]);
            return;
        }
        for (int i = 0; i < selectedDigits.size(); i++) {
            if (isUsed[i] == false) {
                isUsed[i] = true;
                cur.push_back(selectedDigits[i]);
                dfs(selectedDigits, cur, isUsed);
                cur.pop_back();
                isUsed[i] = false;
            }
        }
    }
public:

    /* Write Code Here */
    vector < int > ThreeDigitNumbers(vector < int > selectedDigits) {
        vector<bool> isUsed(5);
        vector<int> cur;
        dfs(selectedDigits, cur, isUsed);
        return res;
    }
};
int main() {
    vector < int > res;

    int selectedDigits_size = 0;
    cin >> selectedDigits_size;

    vector<int> selectedDigits;
    int selectedDigits_item;
    for (int selectedDigits_i = 0; selectedDigits_i < selectedDigits_size; selectedDigits_i++) {
        cin >> selectedDigits_item;

        selectedDigits.push_back(selectedDigits_item);
    }

    Solution* s = new Solution();
    res = s->ThreeDigitNumbers(selectedDigits);
    for (int res_i = 0; res_i < res.size(); res_i++) {
        cout << res[res_i] << endl;;
    }
    return 0;
}

在这里插入图片描述

2. 计算无人机飞行坐标

时间限制: 3000MS
内存限制: 65536KB
题目描述:
编写一个程序,模拟无人机的飞行路径。给定一个包含指令的字符串 (例如:“RUDDLLUR”),每个指令代表无人机在二维平面上移动的方向(U:前、D:后、L:左、R:右),请计算无人机的最终坐标并输出。

输入描述
RUDDLLURRR

输出描述
无人机的最终坐标是: (2, 0)

样例输入
?RUDDLLUR
样例输出
0 0

提示
无人机开始的坐标是(0,0),每执行1个指令,对应坐标方向+1。

#include <iostream>
#include <vector>
#include <numeric>
#include <limits>
#include <string>

using namespace std;

class Solution {
public:

    /* Write Code Here */
    vector < int > calculateFinalPositi(string instructions) {
        int x = 0, y = 0;
        for (int i = 0; i < instructions.size(); i++) {
            if (instructions[i] == 'U') {
                y++;
            }
            else if (instructions[i] == 'D') {
                y--;
            }
            else if (instructions[i] == 'L') {
                x--;
            }
            else if (instructions[i] == 'R') {
                x++;
            }
        }
        vector<int> res(2);
        res[0] = x;
        res[1] = y;
        return res;
    }
};
int main() {
    vector < int > res;

    string instructions;
    getline(cin, instructions);
    Solution* s = new Solution();
    res = s->calculateFinalPositi(instructions);
    for (int res_i = 0; res_i < res.size(); res_i++) {
        cout << res[res_i] << endl;;
    }

    return 0;
}

在这里插入图片描述

文章来源:https://blog.csdn.net/myf_666/article/details/132264207
本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。