苗苗今天刚刚学会使用括号,不过他分不清小括号,中括号,大括号和尖括号,不知道怎么使用这些括号,请帮助他判断括号使用是否正确。
注意:不需要区分括号的优先级。
输入格式
共一行,包含一个由 <,(,{,[,>,),},] 构成的字符串。
输出格式
如果输入的字符串中的括号正确匹配则输出 yes,否则输出 no。
数据范围
输入字符串长度不超过 10000。
输入样例:
(){}
输出样例:
yes
#include<iostream>
#include<stack>
#include<unordered_map>
using namespace std;
stack<int> stk;
unordered_map<char,int> mp={{'<',1},{'>',-1},{'{',2},{'}',-2},
{'[',3},
{']',-3},
{'(',4},
{')',-4}};
int main()
{
string str;
cin>>str;
bool res=true;
for(int i=0;i<str.size();i++)
{
int t=mp[str[i]];
if(t>0) stk.push(t);
else
{
if(stk.size()&&stk.top()==-t)
stk.pop();
else
{
res=false;
break;
}
}
}
if(stk.size()) res=false;
if(res) cout<<"yes";
else cout<<"no";
return 0;
}